[jQuery] jQuery 최근버전에서 $.browser 사용하기

Development Javascript

[jQuery] jQuery 최근버전에서 $.browser 사용하기

1.10.x나 2.x.x에서 ie브라우저를 확인할 수 있는 $.browser값을 사용할 수 있게한다.

$.browser={};(function(){
    jQuery.browser.msie=false;
    $.browser.version=0;if(navigator.userAgent.match(/MSIE ([0-9]+)\./)){
    $.browser.msie=true;jQuery.browser.version=RegExp.$1;}
})();

제이쿼리 오류는 jquery1.9로 업데이트되면서 폐기된게 있는데 브라우저 버전을 체크하는 $.browser입니다.
그래서 제이쿼리로 브라우저 버전체크를 할 수 없게 되었는데 대응책으로 css브라우저 셀렉터라는 js를 사용하면 상당히 괜찮은 방법으로 브라우저 체크가 가능합니다.

플러그인 제작사 홈페이지에 가보니 jquery1.9적용된 패치가 있네요.
http://www.ericmmartin.com/simplemodal-1-4-4-released/